26-08-2012, 12:32   #1
Junior Member
Join Date: Aug 2012
Posts: 1
replaced wearlink strap, still not working
I got a Polar FT4 about six months ago. About a month ago the heart rate readings starting getting really inconsistent and crazy--jumping from 115 to 250 for no reason etc--and then stopped working entirely.

I figured it was my Wearlink strap, as I hadn't realised I was supposed to wash it frequently, so I thought the sensors were probably corroded.

I got a new strap and attached my transmitter thing to it, but the watch still reads zero heart rate. I've tried tightening the strap and moistening the contacts but it doesn't seem to make a difference.

Is there anything else I should try before writing the whole thing off? I'm still in warranty but I can't find the darn receipt so I can't send the thing back...
mskatee is offline Reply With Quote
26-08-2012, 14:13   #2
Join Date: Nov 2011
Posts: 30
"Moistening the contacts" may not be sufficient. Try soaking the strap in water for a minute, to see if it helps.

Did you get a new transmitter with the new strap? If not, the transmitter battery may need replacing.
Dave_L2011 is offline Reply With Quote

Thread Tools