We announced earlier that this forum would close 15th December, 2014. However, we have received many requests to continue discussion forum and decided that Polar discussion forum will stay open until further notice - until we have something better to offer you guys.

Please note that this is a Polar user forum, and that:

  1. The forum is meant for peer support of Polar products and for Polar users sharing their good practices and tips for training.
  2. The forum rules, since 2008, state that Polar will not provide technical assistance at this forum. So, to be able to best serve you we encourage you to contact Polar customer care directly with your issue, bug report, or any other feedback. Through direct contact we can provide you a personalized technical guidance and most efficiently share you feedback with Polar product development.
  3. Polar moderation at this forum means e.g. removing of inappropriate posts, banning spammers, and correcting OR removing of erroneous information about Polar products when encountered.

Thanks for observing the above! Be helpful, be considerate, inspire others to get to their goals, and enjoy sharing with the community!

- Polar Team-
(we do listen)


Reply
20-10-2010, 10:59   #11
aero99
Junior Member
 
Join Date: Jun 2010
Posts: 2
I had to replace the watch battery before trying to connect it. Maybe try that. Otherwise it may be a more complex problem...
aero99 is offline Reply With Quote
20-10-2010, 12:01   #12
ciaranmca
Junior Member
 
Join Date: Oct 2010
Posts: 3
Originally Posted by ciaranmca View Post
How long did you have to wait for connection with RS800?
because it never goes pass the infrared connection window as if it doesn't recognise it!!!

Am leaving for NZ in like 2 weeks cannot send it to polar if it doesn't come back in time! and i need this watch!!!

please help... I've done all of them steps you said
sweet as got it to work!

thanks!
ciaranmca is offline Reply With Quote
Reply

Thread Tools