Reply
06-05-2011, 18:57   #1
natasia
Junior Member
 
Join Date: May 2011
Posts: 2
Problems with Polar WearLink+ transmitter with Bluetooth
yesterday I bought a a polar device. I tracked a bike ride with runkeeper. It was no problem.

But today my moblie (samsung gt i5500) freezes, if wear the Polar device (and bluetooth is swiched on).

Sometimes it is possible to establish a connection and start runkeeper. But after 2 minutes the connection gets lost (or so). You can see it in my heartbeat monitoring (http://runkeeper.com/user/Je-S/activity/34423341 and http://runkeeper.com/user/Je-S/activity/34416038)

So what could be the problem?

lg
natasia
natasia is offline Reply With Quote
06-05-2011, 19:17   #2
MusicLaw
Senior Member
 
MusicLaw's Avatar
 
Join Date: Jan 2010
Location: Woodland Hills, CA - U.S.A.
Posts: 5,663
Is it the Bluetooth connectivity dropping?
Or is your Heart Rate value getting lost?

It could be the application.
It could be your smartphone's Bluetooth pairing.
It could be the Polar WearLink transmitter (not sufficient snug on your chest or not sufficiently saturated before wearing).

Try downloading another application such as www.EndoMondo.com or one of the others which work with your smartphone and the Polar Bluetooth transmitter to isolate if the application, the phone's Bluetooth pairing, or the Polar transmitter may be the problem.
__________________
POLAR® USA AMBASSADOR --- "Commit to Transform!"©

Training Gear:
RS800CX PTE, CS600, Spd/Cad/G5 on MARIN® Alpine29er
RCX5, RC3 GPS, FT80/G1, H2 SoftStrap, Loop H7/H6
FLOW & BEAT, GALAXY® S4 Active, QUAD LOCK®
SKIER'S EDGE® QS5 BigMtn RPM
P90X®, GoFit® PowerTube, Weights
PERFECT® FITNESS MultiGym & PushupV2
LUMINA 650 & MARS3 Lights
K2® BOA MACH100 Skates
HARBINGER® 1260 Gloves
CAMELBAK® Packs
ERGON® GP5 Grips
• RCX3, G3, FT60/40/7, F6, FA20, AW200, M71ti
MusicLaw is offline Reply With Quote
06-05-2011, 19:57   #3
natasia
Junior Member
 
Join Date: May 2011
Posts: 2
Thaks for your answer.
It lost the blootooth connection. The phone tells (in the bluetooth menue) "paired, but not conected".

I dont think thats a problem with the program. I tried other programs.
But the main problem is that my phone freeses all the time, when the polar device is connected. every thing gets realy slow. about 1 minute lag.

Now I un-paired and I am trying to re-pair. But the device cannot be found anymore. It is not possible for me, to figger out, if the device switches on correctly. Or if the battery is empty (shouldn't be empty).

I think the problem is both Blutooth paring (when connected, phone freeze) and the Polar transmitter itself because it dont seems to switch on.

natasia
natasia is offline Reply With Quote
06-05-2011, 20:16   #4
MusicLaw
Senior Member
 
MusicLaw's Avatar
 
Join Date: Jan 2010
Location: Woodland Hills, CA - U.S.A.
Posts: 5,663
Natasia:

Make sure that the Gray mesh sensor strips of the WearLink+ strap are thoroughly saturated under running water before you snap the WearLink+ Transmitter Module to the strap. Just a few drops are not enough!

Then adjust the WearLink+ Chest strap such that it tightly fits around your chest to assure good conductivity with your skin.

Once you have done so, the WearLink+ Transmitter should now be transmitting valid Heart Rate data. So the next step would be to try Pairing it with your phone.

Bluetooth pairing is typically a phone operating system function that has little to do with the application you would next be running. Once your phone recognizes the Bluetooth pairing with the WearLink, you then start your application.

I don't know, but if you remove the strap or unsnap the transmitter from the strap while your application is still running and you application sees the Heart Rate data become null, that may disrupt the application.
__________________
POLAR® USA AMBASSADOR --- "Commit to Transform!"©

Training Gear:
RS800CX PTE, CS600, Spd/Cad/G5 on MARIN® Alpine29er
RCX5, RC3 GPS, FT80/G1, H2 SoftStrap, Loop H7/H6
FLOW & BEAT, GALAXY® S4 Active, QUAD LOCK®
SKIER'S EDGE® QS5 BigMtn RPM
P90X®, GoFit® PowerTube, Weights
PERFECT® FITNESS MultiGym & PushupV2
LUMINA 650 & MARS3 Lights
K2® BOA MACH100 Skates
HARBINGER® 1260 Gloves
CAMELBAK® Packs
ERGON® GP5 Grips
• RCX3, G3, FT60/40/7, F6, FA20, AW200, M71ti
MusicLaw is offline Reply With Quote
19-05-2011, 23:15   #5
DimitrisP
Junior Member
 
Join Date: May 2011
Posts: 3
Where do you have your phone while exercising? In your pocket or in an armband?

I ve read in forums that connection is easily lost if the Android phone is in a bag or pocket. Having the phone in an armband or generally very close to the belt probably helps
DimitrisP is offline Reply With Quote
29-05-2011, 08:50   #6
willem.deboer
Junior Member
 
Join Date: May 2011
Location: Netherlands
Posts: 2
Yesterday I noticed that Runkeeper did display the heartrate correctly while running, but when I looked up the activity online later the heartrate graph went to -1 after 1 km. It looks like Runkeepr somehow did not record the heartrate properly.
Sofar, I have been able to complete correctly only one heatrate recording out of 15 runs! And that was after putting in a new battery.
__________________
Runkeeper+Wearlink + Bluetooth+HTC Hero+Android 2.1
willem.deboer is offline Reply With Quote
30-05-2011, 19:49   #7
willem.deboer
Junior Member
 
Join Date: May 2011
Location: Netherlands
Posts: 2
Confirmed
I've tested again today. Runkeeper displays my heartrate from beginning right to the end of the activity. But the heartrate graph stops halfway. Software problem?
__________________
Runkeeper+Wearlink + Bluetooth+HTC Hero+Android 2.1
willem.deboer is offline Reply With Quote
15-06-2011, 22:29   #8
ddub808
Junior Member
 
Join Date: Jun 2011
Posts: 1
Wearlink w/ Bluetooth
Got a Wearlink w/ Bluetooth last week. Everything hooked up and worked perfectly for two sessions. Session 3... paired up and connect, but then dropped heart rate monitoring midway through my 3 mile work out and sent no HR to app. Session 4 and after... cannot get HRM to connect. Pairs just fine, but no connection. Tried SportsTrackerLive, Endomondo and Runtastic apps. Same issue for all, so it seems to be a phone/monitor connection issue. Since it has worked perfectly on two occasions, it seems my Samsung Vibrant 4g (android) is not the problem. Help!

Does POLAR recommend a preferred app? If so, let me know!!

Thanks!
ddub808 is offline Reply With Quote
10-07-2011, 10:17   #9
RodF
Junior Member
 
Join Date: Jul 2011
Posts: 1
Same problem: hb stops during the workout. For the rest of the workout the heartrate stay's the same. I tried different apps, but all the same problem. I'm wearing my htc desire (android 2.2) in an armband.
RodF is offline Reply With Quote
16-08-2011, 21:28   #10
Antny
Junior Member
 
Join Date: Aug 2011
Posts: 2
Same problem here as well, except I've had no problems getting it to pair with my phone or getting it to sync with my Cardiotrainer app, but it only works for 10 to 20 seconds and then freezes up. The only way to reset it is to turn off bluetooth, exit the application, and start over. But then it only works for 10 to 20 seconds and locks up again. I've also tried it with Endomondo and it does the same thing for that app.
Antny is offline Reply With Quote
Reply

Thread Tools